Some customers may be experiencing declines
Incident Report for Curve
Resolved
Between 12:50 and 13:15 BST, we experienced a disruption to our service, which caused some of our customers to receive declines when making payments. This issue has now been fixed and transactions are being processed as normal. We're very sorry for the inconvenience caused.
Posted Aug 12, 2019 - 12:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2019 - 12:16 UTC
Investigating
We are currently experiencing intermittent issues with processing transactions, meaning some customers may experience a decline when attempting to make a payment. We understand that this is frustrating and we’re sorry about the inconvenience.

We will let you know as soon as the issue has been fixed. We recommend that you carry a backup card during this time.
Posted Aug 12, 2019 - 11:55 UTC
This incident affected: Transactions processing.