Some customers may be receiving duplicate charges
Incident Report for Curve
Resolved
This issue has now been resolved and we are now taking steps to correct any impacted transactions.
Posted Jan 23, 2020 - 13:51 UTC
Identified
We have identified the root cause of the issue and are currently working on implementing a fix. Please be assured any duplicate charges will be refunded once the fix is in place.
Posted Jan 23, 2020 - 13:05 UTC
Investigating
We are currently experiencing intermittent issues with processing transactions, meaning some customers may experience a duplicate charge when attempting to make a payment.

We understand that this is frustrating and we apologise for any inconvenience caused. We are continuing to investigate the issue and will let you know as soon as this has been resolved.

If you have been affected, please be assured any duplicate charges will be refunded. We recommend that you carry a backup card during this time.
Posted Jan 23, 2020 - 11:55 UTC
This incident affected: Transactions processing.