Some customers may be experiencing declines
Incident Report for Curve
Resolved
After investigating this issue, we can confirm that it was an isolated issue and only a very small number of customers were affected. This issue has now been fixed and transactions are being processed as normal. We're sorry for the inconvenience caused.
Posted Sep 16, 2019 - 10:31 UTC
Investigating
We are currently experiencing intermittent issues with processing transactions, meaning some customers may experience a decline when attempting to make a payment. We understand that this is frustrating and we’re sorry about the inconvenience.

We will let you know as soon as the issue has been fixed. We recommend that you carry a backup card during this time.
Posted Sep 16, 2019 - 10:18 UTC
This incident affected: Transactions processing.