Mastercard Processing Issues - Some payments may fail
Incident Report for Curve
Resolved
Transaction processing is now back to normal. We sincerely apologise for the inconvenience.
Posted Jul 12, 2018 - 19:06 UTC
Monitoring
We are seeing an increase in successful transaction processing, however there is no confirmation of a resolution. We will continue to monitor and update as soon as we have any further information.
Posted Jul 12, 2018 - 18:43 UTC
Investigating
We have received a report from Mastercard of an issue affecting Mastercard transactions. We are in regular contact with them and will update as soon as we have anymore information.

While some transactions are failing, others are going through, so if you receive a decline, please try again. Also, please carry a backup card at this time. We apologise for the inconvenience caused.
Posted Jul 12, 2018 - 17:56 UTC
This incident affected: Transactions processing.