Payment Issues
Incident Report for Curve
Resolved
Resolved - Our payment partner is back up and running. We're really sorry about the inconvenience caused in the meantime.
Posted Oct 10, 2017 - 00:27 UTC
Investigating
Payments are currently being declined by our payment processor - we are investigating and will provide an update as soon as we know more. Please carry a backup card. We apologise for the inconvenience
Posted Oct 09, 2017 - 23:23 UTC