Payment Issues - please carry a backup a card!
Incident Report for Curve
Resolved
Our payment processing partner is back up and you can use your Curve card again. Please accept our apology for any inconvenience this may have caused you.
Posted Oct 05, 2017 - 07:27 UTC
Identified
One of our payment partners is having issues processing transactions - your Curve card will be declined. We recommend carrying a backup card until further notice. We're very sorry for the inconvenience and promise to keep you updated.
Posted Oct 05, 2017 - 07:12 UTC