Wallet display issue
Incident Report for Curve
Resolved
Between 10:42 and 11:41 GMT, we experienced a disruption to our service causing all customers to be unable to see their payment cards in their app wallet. This issue has now be resolved. We apologise for the inconvenience caused.
Posted Mar 15, 2019 - 12:00 UTC
Identified
We are currently aware of a display issue in app affecting all customers. You can still make payments, but you won’t be able to switch between payment cards. Our Engineering Team is working on this and will have it fixed as soon as possible. We apologise for any inconvenience caused.
Posted Mar 15, 2019 - 11:25 UTC