Issues adding new payment cards and using the 'go back in time' feature
Incident Report for Curve
Resolved
The issue has been resolved - thank you for your patience. You can now verify new payment cards and use the 'go back in time' feature.
Posted Sep 22, 2018 - 10:32 UTC
Investigating
There's an issue with the 'go back in time' feature as well as verifying new payment cards. We are investigating the issue and working hard to fix it as soon as possible.
Posted Sep 22, 2018 - 08:29 UTC