Intermittent payment processing issues
Incident Report for Curve
Resolved
Our payment processor has confirmed that a solution was deployed and the issue is resolved. Transaction processing is now back to normal. We sincerely apologise for the inconvenience.
We expect transactions to be reconciled in the next 48 hours. Please contact us at support@imaginecurve.com for any questions.
Posted Jul 01, 2018 - 14:52 UTC
Monitoring
One of our payment processing partners is currently experiencing intermittent issues processing transactions, which is causing successful transactions to be immediately reversed. For this reason, you may see this transaction as successful in your app, but it was actually declined.

If a payment is declined, please do try to make the transaction again. We also recommend that you carry a backup card during this time.

We’re sorry about the inconvenience and will let you know as soon as the issue has been resolved.
Posted Jul 01, 2018 - 13:03 UTC
Investigating
One of our payment processing partners is currently experiencing intermittent issues processing transactions. If a payment is declined, please do try to make the transaction again. We recommend that you carry a backup card during this time.

We’re sorry about the inconvenience and will let you know as soon as the issue has been resolved.
Posted Jun 30, 2018 - 12:00 UTC
This incident affected: Transactions processing.